Need help with text-to-speech (can't fill bug report myself)



2018-05-12 20:59

Show all posts
Edited by User5207442276 at 2018-05-12 21:01

Hello, if anyone can help me by filling up a bug report (and check the bug too, just in case), since I don't have enough user previlegies, I'll greatly appreciate it.
Here's the thing:

Device: pro 7
Build: Flyme
No root

Bug: unable to change TTS (text-to-speech) engine to non-stock one.

Details: By going to Settings > Accessibility > Text-to-speech output, and attempting to switch preferred engine, despite having 3rd party engine installed (Ivona TTS, for instance), working, and marked as "preferred", upon using an application that has TTS capabilities (AlReader, for instance), the 3rd party engine doesn't work. Instead, stock TTS engine (Google TTS) is working.
I have tried freezing Google TTS apk, while retaining only Ivona TTS, but in this case TTS didn't work.
I have tried re-building Google TTS apk and changing the package name, installing modified Google TTS while system one is freezed, in this case TTS didn't work (Apparently, OS only recognizes stock Google TTS as only viable engine and allows no overrides?)
I have tried readers with built-in TTS engines and they work, but these applications don't suit my needs (can't play text while screen is off, for instance).

In case you know any workarounds - please share them. My main purpose is to use Ivona TTS + AlReader to listen to books with device screen off, without internet access.