Problems with Google Services and 4G Network



2017-12-23 14:18

Show all posts
Edited by Veliary at 2017-12-23 14:56

Hi, Flyme Forum!
I'll be needing some help here. I'll try to describe my problem as clear as possible, so bear with my long post.
At first my Google Play just can't connect to network and the same problem occured when I tried to add new Google account. So I tried to uninstall and reinstall Google Services from GMS, and the uninstallation stucks for half-a-day.

And then I decided to just reset my device with factory reset, it successfully rebooted with FlymeOS version (when I buy the phone it runs on Flyme version 5 I believe). But my problem wasn't solved, I still can't connect to Google network even after reinstalling with newer version of GMS I downloaded from Meizu App Store. And suddenly, my device can't use 4G LTE network. The option to change the network to "4G First" just dissapeared and I don't know what to do.

My Meizu M3S just finished getting hard reset (factory reset) again and it is running FlymeOS version Anyone can help me please?