Using HD voice (VOLTE) with Jio 4G network in India without Jiojoin app.



2016-08-22 22:26

Show all posts
Edited by viki4vikram at 2016-08-22 23:18

Hi All,

From last few months Jio 4G is making rounds of news and it was available only to limited - partnered brands like samsung / Lyf, etc.
and those who were able to grab the sim cards were having difficult time using it with Meizu phones as they were not able to call/sms using VOLTE (HD Voice in flyme).

So I have come up with a temporary solution to fix the situation and enable the HD voice in Meizu m3 note. (This may work in M2 also - if it has HD voice option in settings , but I have not tested it personally as I do not have that device now )

Steps to use VOLTE in Meizu M3 note :

Part 1 :

  • Go to settings > SIMs and networks > APNs > (Select the jio sim) > Add APN (we will have to use two APNs here - so add them if not present)

  • 1st APN will be to use 4G data with Jionet as APN and default as apn type , dont touch the other fields (probably you will be using this by now)




  • 2nd APN will be to call and send sms through VOLTE. - use the following settings :

       Name : ims
       APN   : ims
       APN type : ims
       APN protocol : ipv4 / ipv6

       Do not touch the other fields.  - > Save



Now, your APNs should look like this :



Part 2 : This is a little complex part for normal users as this involves engineering mode edits.
"Proceed with caution"
  • Enter engineering mode by dialing  *#*#3646633#*#* from your phone dialer.
  • Go to Connectivity menu by swyping one time to the left from Telephony menu.
  • Select CDS information  > Multiple APN
       Now you see a list MMS will be the first option with down arrow, click on that and
       select IMS and click START button.

ims select.jpg

It should look like this after starting :

final ims.jpg   

   4. Now come back two times and swype right to see Telephony menu in engineering mode.
  • Click on IMS
  • Click on USSD > Ussd Support > select ON and set

   5. Again come to common menu (inside IMS menu)
  • Select operator_code > select VoLTE_Operator_RJIL from the big list > click on set

   6. Come back twice (to IMS menu)

  • Click on Common > mncmcc check > select OFF and set


DONE .. Now click home button, exit engineering mode and check for HD voice symbol. If you see that , try calling any number from the default dialer - Fast method is to call the customer care number 199 to check if the calls are getting connected or not.

Now everything is setup.
If your phone is not showing HDvoice symbol beside the battery icon even if the HD voice is turned ON in settings (it will be next to data sim selection), try to turn off the sim and start it back (Just go to airplane mode and come back), check.

Any questions are welcome.