Google Play Services not working

21036

104

2018-07-15 03:33

Show all posts
Edited by ExDec at 2018-07-15 23:29

I am from Latvia and I have Meizu M2 Note with Flyme 5.1.11.0G installed. First of all, I'm not updating it to Flyme 6.0.3 because after the update my phones user interface keeps crashing and restarting (I have updated it clearing all data, doing hard reset and updating and nothing helped).
But now my biggest problem is that Google Play Services just stopped working. Gmail, Youtube and other apps from Google show error saying that Google Play Services is not available for my phone. But I have the latest version of Google Play Services installed.
I tried contacting Google and they told me to contact you (which probably won't work since there was a topic about this and no help was given).
I have tried removing Google Play Services and Play Store, clearing cache, restarting phone, even hard reset and it doesn't work anymore. So clearly something is going on between Google and Meizu and phone users have to suffer.

So is there a fix for this that doesn't include updating Flyme? Or maybe a fix for user interface crashes after update?

I can give Google Support chat reference ID (although there wasn't anything useful in that chat because Googles support is just as useless as any other support).